Degraded Performance

Incident Report for Athennian

Resolved

This incident has been resolved.
Posted Mar 06, 2026 - 16:47 MST

Identified

We are currently investigating reports of increased latency and intermittent slowdowns across our platform. Our engineering team is actively working on mitigation strategies to restore normal performance levels.

We will provide another update as soon as more information is available.
Posted Mar 06, 2026 - 14:30 MST
This incident affected: Athennian APP (Canada).