The site is currently back online, though some components may still experience intermittent degradation or elevated latency.
AWS continues to work on restoring the affected infrastructure and services within the Middle East region. While our primary services are recovering, we are keeping the incident open as we monitor system stability and wait for final confirmation of full resolution from AWS.
Posted Mar 06, 2026 - 14:54 MST
Update
Update Status
Posted Mar 02, 2026 - 10:28 MST
Identified
Incident Update: Monitoring Status: Monitoring
Message: The site is currently back online, though some components may still experience intermittent degradation or elevated latency.
AWS continues to work on restoring the affected infrastructure and services within the Middle East region. While our primary services are recovering, we are keeping the incident open as we monitor system stability and wait for final confirmation of full resolution from AWS.
Current Impact:
Site Accessibility: Restored.
Performance: Some features or API endpoints may still show signs of sluggishness.
DR Protocols: We are verifying the availability of our Bahrain DR site as AWS services stabilize.
We are continuing to monitor the situation closely and will provide a final update once we are confident in full service restoration.
Posted Mar 02, 2026 - 10:27 MST
This incident affects: Athennian APP (Middle East).