Issues with Google login
Incident Report for Athennian
Resolved
This incident has been resolved.
Posted Aug 19, 2019 - 13:59 MDT
Identified
Some users have reported google login not working through the website. This has been reported by users of other sites as well. https://outage.report/google. We will let you know once google has the service up and running again. We apologize for any inconvenience that this may cause
Posted Aug 19, 2019 - 13:00 MDT