This incident has been resolved. The issue causing documents and folders to appear missing in Minute Books for a subset of entities has been fixed, and we've confirmed normal behavior is restored. If you continue to experience any issues, please contact support.
Posted Aug 28, 2026 - 21:51 MDT
Monitoring
A fix has been applied to resolve the issue causing documents and folders to appear missing in Minute Books for a subset of entities. We are monitoring the results to confirm full resolution. If you continue to experience this issue, please contact support.
Posted Aug 28, 2026 - 15:01 MDT
Identified
We have identified the cause of the issue affecting document and folder visibility in Minute Books for a subset of entities. Our engineering team is actively working on a fix and validating it before rollout. We will provide another update once the fix has been applied or as new information becomes available.
Posted Aug 28, 2026 - 13:00 MDT
Investigating
We are investigating reports that a subset of entities' Minute Books are showing documents and/or folders as missing. Our engineering team is actively investigating the root cause. We will provide an update as more information becomes available.
Posted Aug 28, 2026 - 11:30 MDT
This incident affected: Athennian APP (Canada), Athennian APP (US), and Athennian APP (Europe).